0-4-0 charging

Post Reply
Glenn Habrial
Associate Member
Posts: 1242
Joined: Tue Apr 24, 2001 4:00 am

0-4-0 charging

Post by Glenn Habrial » Thu Jul 19, 2012 1:11 pm

I have forgotten, is the charging light supposed to turn green when charged on the 0-4-0 when fully charged? I hadden't used my 0-4-0 in awhile and decided to get it out. I plugged it in and it indicated red. I forgot about it and went to bed. early in the morning I remembered got up and saw it still red, also the tender was warm, not hot. I hope I didn't toast the battery.

R.J DeBerg
Associate Member
Posts: 12850
Joined: Mon Sep 19, 2005 4:00 am

Post by R.J DeBerg » Thu Jul 19, 2012 2:55 pm

If I recall the 0-4-0 should turn green. The Mike only went to yellow. Don't know if you fried the battery you will know when you go to use it. Later RJD
President and Chief Engr Dakota and Southern

Glenn Habrial
Associate Member
Posts: 1242
Joined: Tue Apr 24, 2001 4:00 am

Post by Glenn Habrial » Thu Jul 19, 2012 6:44 pm

That will be tonight, I plan on running it to see what works.

Nico Corbo
Associate Member
Posts: 455
Joined: Wed Nov 11, 2009 5:59 pm

Post by Nico Corbo » Thu Jul 19, 2012 9:16 pm

Glenn,
What time should I be there?

LOL
Nico Corbo
Pocono Mountain Garden Railway Society
http://WWW.PMGRRS.COM
PMGRRS@yahoo.com

Glenn Habrial
Associate Member
Posts: 1242
Joined: Tue Apr 24, 2001 4:00 am

Maybe tonight.

Post by Glenn Habrial » Fri Jul 20, 2012 12:24 pm

I didn't get to run it last nigh but perhaps tonight.

Jerry Barnes
Associate Member
Posts: 1453
Joined: Mon Feb 05, 2001 5:00 am

Re: 0-4-0 charging

Post by Jerry Barnes » Sun Dec 13, 2015 3:49 pm

Will the Mikado charger work on the 0-4-0? I seem to have lost mine. Anyone have an extra??

R.J DeBerg
Associate Member
Posts: 12850
Joined: Mon Sep 19, 2005 4:00 am

Re: 0-4-0 charging

Post by R.J DeBerg » Mon Dec 14, 2015 1:24 pm

Yep it will work Jerry. Later RJD
President and Chief Engr Dakota and Southern

Jerry Barnes
Associate Member
Posts: 1453
Joined: Mon Feb 05, 2001 5:00 am

Re: 0-4-0 charging

Post by Jerry Barnes » Wed Dec 16, 2015 4:38 am

Thanks RJ, seemed to work fine.

Post Reply